Server Degradation
Resolved
Apr 17, 2025 at 02:53am UTC
Services have restored to normal and are stable. We are monitoring for any further issues.
Affected services
Updated
Apr 16, 2025 at 11:57pm UTC
Orders can be placed and the site can be accessed, but we recommend not starting any practice exams during this time.
Affected services
Updated
Apr 16, 2025 at 11:15pm UTC
Our service provider has identified the issue and implementing a fix. We suggest not starting any practice exams during this time as the issue may occur during that time.
We apologise for any incovenience.
Affected services
Created
Apr 16, 2025 at 08:16pm UTC
We are aware of an issue with the Platform which is showing a "Database Error". There is a service issue with our provider which we have contacted. We are awaiting an update from them at this time.
Affected services