Back to overview
Degraded

PayPal Payments on Hold

Oct 01 at 09:30am AEST
Affected services
Focus on Force - Payment Method - PayPal

Resolved
Oct 01 at 10:00pm AEST

The PayPal payments have now been resolved and all orders are completing as expected.

Thanks for your patience and understanding. Should you continue to have issues, please contact support via support@focusonforce.com

Created
Oct 01 at 09:30am AEST

Unfortunately PayPal Payments at this time require manual verification by our Support Team.

We are working on a resolution to get automatic verification in place. We have no ETA at this time.

Please reach out to support@focusonforce.com should you have your order placed "On Hold".